Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 02 Dec 2011 15:25:48 +1000
From:      Da Rock <freebsd-questions@herveybayaustralia.com.au>
To:        Adam Vande More <amvandemore@gmail.com>
Cc:        "freebsd-questions@freebsd.org" <freebsd-questions@freebsd.org>
Subject:   Re: Installing an older version of a port
Message-ID:  <4ED8615C.1030100@herveybayaustralia.com.au>
In-Reply-To: <CA+tpaK2QVQ5BHjwgM_4d+SxU1chGvQDSyEnszpcW8nBTfzzkCQ@mail.gmail.com>
References:  <4ED84C36.8090702@herveybayaustralia.com.au> <CA+tpaK2QVQ5BHjwgM_4d+SxU1chGvQDSyEnszpcW8nBTfzzkCQ@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 12/02/11 14:01, Adam Vande More wrote:
> On Thu, Dec 1, 2011 at 9:55 PM, Da Rock 
> <freebsd-questions@herveybayaustralia.com.au 
> <mailto:freebsd-questions@herveybayaustralia.com.au>> wrote:
>
>     I've never actually done this before, so I'm a little shaky on the
>     details.
>
>     ffmpeg-0.7.7,1 doesn't work for my purposes: ffserver/ffmpeg
>     aren't communicating all that well- I'm still working out the
>     details, but essentially either or both are borked. I've been
>     working with the ffmpeg list to sort it out.
>
>     FFmpeg-devel doesn't work either (for whatever reason- again
>     communicating upstream for support, although the maintainer might
>     put opencv as broken in that port), so I'm left with 0.7.6,1 which
>     does appear to work at this point.
>
>     My question is this: how do I do this exactly? The dependencies
>     will require updating and could fail as well right? I tried a
>     pkg_create of the port and installing it where required, but it
>     requires pciids-20111002 and pciids-20111109 is installed (and
>     probably required by other ports). How can I install the older
>     version without breaking things (at least too much- I can fix
>     things but there is usually always a limit)?
>
>     My system is 8.1-RELEASE-p1 FreeBSD 8.1-RELEASE-p1 #1: Sun Mar 13
>     08:45:42 EST 2011 /usr/obj/usr/src/sys/MEDIA  amd64. I have
>     portupgrade and updated to the latest ports (apparently that is
>     the problem- although I've only been fiddling with ffmpeg and it
>     is not in production with my project task per se).
>
>
> http://www.oldports.org/data/
I already have a copy of the port required as a pkg, but how do I handle 
the dependencies?



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4ED8615C.1030100>