Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 18 Nov 2009 08:33:33 -0800
From:      Norbert Papke <npapke@acm.org>
To:        freebsd-questions@freebsd.org
Subject:   Re: ELF library not found error
Message-ID:  <200911180833.33918.npapke@acm.org>
In-Reply-To: <7B9397B189EB6E46A5EE7B4C8A4BB7CB33A5FA3E@MBX03.exg5.exghost.com>
References:  <7B9397B189EB6E46A5EE7B4C8A4BB7CB33A5FA10@MBX03.exg5.exghost.com> <7B9397B189EB6E46A5EE7B4C8A4BB7CB33A5FA34@MBX03.exg5.exghost.com> <7B9397B189EB6E46A5EE7B4C8A4BB7CB33A5FA3E@MBX03.exg5.exghost.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On November 18, 2009, Peter Steele wrote:
> I just installed compat6x-amd64-6.4.604000.200810_3.tbz and that solved the
>  error for Python 2.5 and 3.1, as well as several other applications that
>  were giving that error. I'm still getting the error for a few other
>  packages though, e.g. wireshark:
> 
> # pkg_add /mnt/ports/wireshark-1.2.2.tbz
> pkg_add: warning: package 'wireshark-1.2.2' requires 'tiff-3.9.1_1', but
>  'tiff-3.9.1' is installed pkg_add: warning: package 'wireshark-1.2.2'
>  requires 'pcre-8.00', but 'pcre-7.9' is installed pkg_add: warning:
>  package 'wireshark-1.2.2' requires 'xcb-util-0.3.6_1', but
>  'xcb-util-0.3.6' is installed pkg_add: warning: package 'wireshark-1.2.2'
>  requires 'libxml2-2.7.6', but 'libxml2-2.7.5' is installed root@:~>
> # wireshark
> ELF interpreter /libexec/ld-elf.so.1 not found
> 
> If both the 6.x and 7.x compatibility packages are installed and this error
>  still occurs, what's the culprit?

Presumably (and I am speculating), the 8.0 packages are not yet finalized and 
therefore inconsistent.  Perhaps you will have better luck after the official 
8.0 Release?

-- Norbert Papke.
   npapke@acm.org


http://saveournet.ca
Protecting your Internet's level playing field



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200911180833.33918.npapke>