Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 26 Aug 2011 21:33:46 -0500
From:      Antonio Olivares <olivares14031@gmail.com>
To:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   how can I use portmaster to update but skip a package
Message-ID:  <CAJ5UdcMzaFjEy80PGAOD6R8kUeQmK7wo3xC4CSgAMi9C5OfGkg@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Dear folks,

I am trying to update one of my machines and I ran portmaster -a and got errors:

http://forums.freebsd.org/showthread.php?p=145268

I overcome most by unselecting GNUTLS from cups-image and cups-base,
and then comes

===>>> Launching child to update libreoffice-3.3.3_2 to libreoffice-3.4.2_1

===>>> Port directory: /usr/ports/editors/libreoffice

	===>>> This port is marked BROKEN
	===>>> build is too fragile and break too often -- try libreoffice-legacy

	===>>> If you are sure you can build it, remove the
	       BROKEN line in the Makefile and try again.

===>>> Update for libreoffice-3.3.3_2 failed
===>>> Aborting update

Is there a way to update most packages except this one?

or should I uninstall it and reinstall it again later?  This is not
optimal, but it would be something I can try.  I would prefer not to
do this :(

Thanks in advance,

Antonio



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAJ5UdcMzaFjEy80PGAOD6R8kUeQmK7wo3xC4CSgAMi9C5OfGkg>