Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 21 Nov 2006 21:20:16 +0100
From:      Beni <beni@brinckman.info>
To:        Kent Stewart <kstewart@owt.com>
Cc:        aharrison@gmail.com, freebsd-questions@freebsd.org
Subject:   Re: error in portupgrading audio/amarok
Message-ID:  <200611212120.17017.beni@brinckman.info>
In-Reply-To: <200611191900.43496.kstewart@owt.com>
References:  <200611191328.58426.beni@brinckman.info> <200611191900.43496.kstewart@owt.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Monday 20 November 2006 04:00, you wrote:
> On Sunday 19 November 2006 04:28, you wrote:
> > Hi,
> >
> > When trying to portupgrade amarok, I'm getting the following error. I
> > did already a "make config" and unchecked the iPod option cause I
> > don't need the iPod support. But the upgrade still fails.
> > Any hints on how to get audio/amarok upgraded please?
>
> This is a strange one. I had no problem building amarok, so, I wonder if
> you have dependancies that are out of date. You may have to
> portupgrade -Rf amarok
>
> It this works, then, your system is really out of whack and you have
> other programs with dependancies that need to be built. I would figure
> this was from not upgrading the gnome stuff properly.
> See /usr/ports/UPDATING.
>
> Kent
>

Well, Andy Harisson told me to :

This has to do with the Gnome upgrade. =C2=A0Go here and read the part
about using the find command and grepping for old libtool archives on
your system.
http://www.freebsd.org/gnome/docs/faq2.html#q2

But the strange part is that i'm using kde and not at all gnome... But i=20
suppose that due to the installation of certain programs (like amarok ?),=20
certain deps from gnome do get installed also.

I followed the steps from the gnome faq and relaunched a portupgrade -rR of=
=20
amarok. It completed without any problem now.

To keep my ports updated, i do a "portsnap fetch update" and then=20
a "portmaster -a -i -v" to get all updated what needs to be updated.=20

Thanks for the help !

Beni.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200611212120.17017.beni>