Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 8 Dec 1995 19:33:15 +0000 ()
From:      Sergio Lenzi <lenzi@cwbtwo.bsi.com.br>
To:        questions@freebsd.org
Subject:   NIS/YP problem
Message-ID:  <Pine.BSF.3.91.951208191448.13113A-100000@cwbtwo>

Next in thread | Raw E-Mail | Index | Archive | Help


Hello all,

I run a site here in Brazil with FreeBSD.
Several computers, 6 in one net,and 2 in anoter

    C1      C2       C3      C4       C5        C6
    |       |        |       |        |         |
    0-------0--------0-------0--------0---------0-----------------CA
                                                                   |
                                                                   |
                                                        0----------0
                                                        |
                                                        CB

That is, on CA I have two ethernet adapters.

on net CA-c1 I have 200.250.250.17...23 netmask 0xfffffff0
on net CA-CB I have 200.250.250.1...14 netmask 0xfffffff0

The routes are static, broadcast 200.250.250.255.

There are an YP server on CA, with passwd maps and so on.
The hole system sees passwd maps as machines c1,c2...c6,cb all run
ypbind.

The problem:  when I try to run ypbind on CA, it
reports not finding the server for the domain.

I have seen in the doc that the command ypset is used to
tell the ypbind to look for a server in an address. (ypset not found)

In the code for ypbind it uses an rpc_broadcast... (no man for it).

The question: Whow ypbind finds a server given the domain? 
	by means of a broadcast?

Any ideas???


Sergio de Almeida Lenzi.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?Pine.BSF.3.91.951208191448.13113A-100000>