Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 12 Oct 2004 10:36:27 +0200
From:      =?iso-8859-1?Q?Roub=EDcek_Zdenek_=28T-Systems_PragoNet=29?= <Zdenek.Roubicek@pragonet.cz>
To:        <freebsd-current@freebsd.org>
Subject:   Broadcom bge and 802.1Q vlan tags
Message-ID:  <9256D57F598E6C41B288AA7DB94F29C902DFB963@pgnmail1.pgnaplikace.cz>

Next in thread | Raw E-Mail | Index | Archive | Help

 Hello current

 I have run into a problem with my Broadcom NIC (Dell LATITUDE D600). I =
am not able to detect 802.1Q tags on incoming interface with ethereal or =
tcpdump. All incoming packets seems like they are not coming through =
trunk but as native ETH frames, ie. the vlan tag is missing, probably =
removed before being passed to tcpdump?

No I have not tested NIC's behaviour on 4.X, but I is working with linux =
(2.6.something kernel probably?)

Any ideas what to modify or set so I can detect vlan_tag would be very =
apreciated.

Regards, zdenek

Here is what I believe to be of interest:

spaca-ntb# uname -a
FreeBSD spaca-ntb.prago.net 5.3-BETA7 FreeBSD 5.3-BETA7 #2: Mon Oct 11 =
22:59:16 CEST 2004     =
root@spaca-ntb.prago.net:/usr/obj/usr/src/sys/GENERIC  i386

spaca-ntb# dmesg | grep bge
bge0: <Broadcom BCM5705M Gigabit Ethernet, ASIC rev. 0x3001> mem =
0xfaff0000-0xfaffffff irq 11 at device 0.0 on pci2
miibus0: <MII bus> on bge0

spaca-ntb# pciconf -v -l
...
bge0@pci2:0:0:  class=3D0x020000 card=3D0x865d1028 chip=3D0x165d14e4 =
rev=3D0x01 hdr=3D0x00
    vendor   =3D 'Broadcom Corporation'
    device   =3D 'BCM5705M Broadcom NetXtreme Gigabit Ethernet'
    class    =3D network
    subclass =3D ethernet
...

spaca-ntb# ifconfig
bge0: flags=3D8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=3D1a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
        inet6 fe80::20d:56ff:fee2:edc4%bge0 prefixlen 64 scopeid 0x1
        ether 00:0d:56:e2:ed:c4
        media: Ethernet 100baseTX <full-duplex>
        status: active
plip0: flags=3D108810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=3D8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet 127.0.0.1 netmask 0xff000000
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
vlan100: flags=3D8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        inet6 fe80::20d:56ff:fee2:edc4%vlan100 prefixlen 64 scopeid 0x4
        inet 212.67.71.34 netmask 0xffffff00 broadcast 255.255.255.252
        ether 00:0d:56:e2:ed:c4
        media: Ethernet 100baseTX <full-duplex>
        status: active
        vlan: 100 parent interface: bge0

spaca-ntb# sysctl -a | grep fastforw
net.inet.ip.fastforwarding: 0

spaca-ntb# tcpdump -n -v -i bge0 host acc1.prago.net
tcpdump: WARNING: bge0: no IPv4 address assigned
tcpdump: listening on bge0, link-type EN10MB (Ethernet), capture size 96 =
bytes
10:26:07.764778 IP (tos 0x10, ttl  62, id 16761, offset 0, flags [DF], =
length: 52) 212.67.64.3.4073 > 212.67.71.34.22: . [tcp sum ok] ack =
825352345 win 15136 <nop,nop,timestamp 527892104 104052>
10:26:08.757016 IP (tos 0x10, ttl  62, id 16762, offset 0, flags [DF], =
length: 52) 212.67.64.3.4073 > 212.67.71.34.22: . [tcp sum ok] ack 241 =
win 15136 <nop,nop,timestamp 527892203 104152>
10:26:09.756784 IP (tos 0x10, ttl  62, id 16763, offset 0, flags [DF], =
length: 52) 212.67.64.3.4073 > 212.67.71.34.22: . [tcp sum ok] ack 465 =
win 15136 <nop,nop,timestamp 527892303 104252>
etc.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?9256D57F598E6C41B288AA7DB94F29C902DFB963>