Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 29 May 2020 11:09:51 -0300
From:      Mario Lobo <lobo@bsd.com.br>
To:        "freebsd-questions@freebsd.org" <freebsd-questions@freebsd.org>
Subject:   Sound problems.
Message-ID:  <CA+yoEx9P6Rb8RdGFE8egwCqQ0JRH-FK3craq_KTf9hGMum6TkQ@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi;

FreeBSD 13-CURRENT

I have the following:

Installed devices:
pcm0: <NVIDIA (0x0051) (HDMI/DP 8ch)> (play)
pcm1: <NVIDIA (0x0051) (HDMI/DP 8ch)> (play)
pcm2: <Realtek ALC892 (Rear Analog 7.1/2.0)> (play/rec) default
pcm3: <Realtek ALC892 (Front Analog)> (play/rec)
pcm4: <Realtek ALC892 (Onboard Digital)> (play)
pcm5: <Realtek ALC892 (Rear Digital)> (play)
pcm6: <USB audio> (rec)

hw.snd.default_unit: 2

Which yields this:

mixer
Mixer vol      is currently set to  84:84
Mixer pcm      is currently set to 100:100
Mixer speaker  is currently set to  74:74
Mixer line     is currently set to   1:1
Mixer mic      is currently set to  83:83
Mixer mix      is currently set to  54:54
Mixer rec      is currently set to  96:96
Mixer igain    is currently set to  47:47
Mixer ogain    is currently set to  62:62
Recording source: mic

The realtek mic doesn't work. I tried everything I could. The microphone
sound goes out to the speakers, apps (firefox) detect a mic but its input
doesn't go back into the system. So I wanted to switch the recording source
pcm6, so:

sysctl hw.snd.default_unit=6

which yields this:

mixer
Mixer mic      is currently set to  95:95

i.e., I won't be able to hear a damn thing, and applications won't detect a
mic.

The web cam/realtek combination works perfectly on Linux/Windows.

Any advice (besides "use Linux/Windows") on how to fix this?


-- 
Mario Lobo
http://www.mallavoodoo.com.br
FreeBSD since version 2.2.8 [not Pro-Audio.... YET!!]



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CA+yoEx9P6Rb8RdGFE8egwCqQ0JRH-FK3craq_KTf9hGMum6TkQ>