Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 19 Nov 2006 13:28:58 +0100
From:      Beni <beni@brinckman.info>
To:        freebsd-questions@freebsd.org
Subject:   error in portupgrading audio/amarok
Message-ID:  <200611191328.58426.beni@brinckman.info>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi,

When trying to portupgrade amarok, I'm getting the following error. I did 
already a "make config" and unchecked the iPod option cause I don't need the 
iPod support. But the upgrade still fails.
Any hints on how to get audio/amarok upgraded please?

Thankx,
Beni.

[...]
Making all in ipod
gmake[5]: Entering directory 
`/usr/ports/audio/amarok/work/amarok-1.4.4/amarok/src/mediadevice/ipod'
/usr/X11R6/bin/moc ./ipodmediadevice.h -o ipodmediadevice.moc
if /bin/sh /usr/local/bin/libtool --silent --mode=compile --tag=CXX 
c++ -DHAVE_CONFIG_H -I. -I. -I../../../.. -I../../../../amarok/src -I../../../../amarok/src -I../../../../amarok/src/amarokcore -I../../../../amarok/src/amarokcore -I../../../../amarok/src/engine -I../../../../amarok/src/engine -I../../../../amarok/src/mediadevice -I/usr/local/include/gpod-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include   -I/usr/local/include/taglib -I/usr/local/include -I/usr/X11R6/include  -I/usr/local/include  -D_THREAD_SAFE -pthread -DQT_THREAD_SUPPORT   -I/usr/local/include -I/usr/local/include  -I/usr/X11R6/include -D_GETOPT_H -D_THREAD_SAFE   -Wno-long-long -Wundef -Wall -W -Wpointer-arith -O2 -fno-strict-aliasing -pipe -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION  -MT 
ipodmediadevice.lo -MD -MP -MF ".deps/ipodmediadevice.Tpo" -c -o 
ipodmediadevice.lo ipodmediadevice.cpp; \
        then mv -f ".deps/ipodmediadevice.Tpo" ".deps/ipodmediadevice.Plo"; 
else rm -f ".deps/ipodmediadevice.Tpo"; exit 1; fi
/bin/sh /usr/local/bin/libtool --silent --mode=link --tag=CXX 
c++  -Wno-long-long -Wundef -Wall -W -Wpointer-arith -O2 -fno-strict-aliasing -pipe -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o 
libamarok_ipod-mediadevice.la -rpath /usr/local/lib/kde3 -avoid-version -module -no-undefined  -R /usr/local/lib -R /usr/local/lib -R /usr/X11R6/lib -R /usr/X11R6/lib -R /usr/local/lib -D_THREAD_SAFE -pthread -L/usr/local/lib -lgpod -lglib-2.0 -liconv   -L/usr/local/lib -L/usr/X11R6/lib   -D_THREAD_SAFE -pthread  -L/usr/local/lib 
ipodmediadevice.lo ../../../../amarok/src/libamarok.la -Wl,-export-dynamic -L/usr/local/lib -L/usr/X11R6/lib -ljpeg  -L/usr/X11R6/lib
grep: /usr/X11R6/lib/libgdk_pixbuf-2.0.la: No such file or directory
sed: /usr/X11R6/lib/libgdk_pixbuf-2.0.la: No such file or directory
libtool: link: `/usr/X11R6/lib/libgdk_pixbuf-2.0.la' is not a valid libtool 
archive
gmake[5]: *** [libamarok_ipod-mediadevice.la] Error 1
gmake[5]: Leaving directory 
`/usr/ports/audio/amarok/work/amarok-1.4.4/amarok/src/mediadevice/ipod'
gmake[4]: *** [all-recursive] Error 1
gmake[4]: Leaving directory 
`/usr/ports/audio/amarok/work/amarok-1.4.4/amarok/src/mediadevice'
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory 
`/usr/ports/audio/amarok/work/amarok-1.4.4/amarok/src'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.4/amarok'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/audio/amarok/work/amarok-1.4.4'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/audio/amarok.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.25870.68 
env PORT_UPGRADE=yes make
** Fix the problem and try again.
** Listing the failed packages (*:skipped / !:failed)
        ! audio/amarok (amarok-1.4.3_3) (missing header)
--->  Packages processed: 0 done, 106 ignored, 0 skipped and 1 failed
www#   



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200611191328.58426.beni>