Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 25 Apr 2006 13:27:08 -0400
From:      John Nielsen <john@jnielsen.net>
To:        freebsd-questions@freebsd.org
Cc:        Per =?iso-8859-1?q?Dahlstr=F8m?= <dahlstrm@post9.tele.dk>
Subject:   Re: AWT
Message-ID:  <200604251327.09078.john@jnielsen.net>
In-Reply-To: <000001c66880$72cba890$6701a8c0@PDAitetots>
References:  <000001c66880$72cba890$6701a8c0@PDAitetots>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Tuesday 25 April 2006 11:53, Per Dahlstr=F8m wrote:
> I am a happy user of FREEBSD, or rather I were happy but still a user.
> Actually it is my WebHotel running FREEBSD, which I became aware of in a
> not so pleasant way.
>
> While developing my site I realised that I could not use Java AWT and
> Swing packages. My Hotel supplier then informed me that AWT and Swing is
> not available at the moment.
>
> So, here is my question: Is it true?

=46reeBSD supports Java and has for some time.  As far as I know, any JRE o=
r JDK=20
based on Java 1.4.2 or 1.5.0 will support both AWT and Swing.

A recent development made it much easier to obtain and run run "native"=20
=46reeBSD java packages, obviating the need in most cases to run a Linux bi=
nary=20
and/or to compile the JDK from source.  See=20
http://www.freebsdfoundation.org/downloads/java.shtml for more information.

JN



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200604251327.09078.john>