Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 16 Nov 2020 12:49:00 +0100
From:      Polytropon <freebsd@edvax.de>
To:        "Thomas Mueller" <mueller6722@twc.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Booting multiple BSDs.
Message-ID:  <20201116124900.be157ef7.freebsd@edvax.de>
In-Reply-To: <202011161116.0AGBGgLt001902@r56.edvax.de>
References:  <fecab1ac1f5589d9f2122ae2c37edfac@riseup.net> <cmu-lmtpd-1514294-1605257963-2@sloti22d2t03> <3c5506c0-9727-4773-43c9-5afe9767ad9f@xsmail.com> <202011161116.0AGBGgLt001902@r56.edvax.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Mon, 16 Nov 2020 09:45:01 +0000, Thomas Mueller wrote:
> > > > Harry Weaver
>        
> > > --  
> > > �\200⣴� �� �⢶⣦� \2_ONE(0.00
> > > > ⣾� \201� � \222� \200⣿�\201 Debian - The universal operating system 
> > > > ⢿�\204� \230� �� \232� \213� \200 https://www.debian.org
> > > � \210� ��\204� \200� \200� \200� \200
>        
> > > What are those strange characters in the footer of your message, after the "--" line?  I can't read them as anything rational: look like hexadecimal codes.
>         
> > Those look correct here -- ascii-like debian logo -- even in console (vt with
> > terminus font), are you using non-UTF-8-capable MUA yet?
> 
> Now with a less-outdated version of NetBSD and less-outdated version of Xorg, I get better, though I still don't see any fancy Debian logo: looks like
> 
> ⢀⣴⠾⠻⢶⣦⠀
> ⣾⠁⢠⠒⠀⣿⡁ Debian - The universal operating system
> ⢿⡄⠘⠷⠚⠋⠀ https://www.debian.org
> ⠈
> which is not what I'm running now.

Looks like there is still more than one 2-to-1 byte mangling
involved, possibly crossing encoding borders. If you have
further questions, ask Senior Lampampatilde-Ampamsuppez who
lives in Schlatildefracterstrasse, Berlin... ;-)

The original message declares UTF-8 correctly, and also _uses_
UFT-8 encoded symbols in the signature. The following drawing
should be visible:

	⢀⣴⠾⠻⢶⣦
	⣾⠁⢠⠒⠀⣿⡁
	⢿⡄⠘⠷⠚⠋
	⠈⠳⣄

If there is some back-and-forth nonsense ISO-8859-1 <-> UTF-8
and maybe some HTML guessing (some web mailers tend to do this
in order to "help"), useless multibyte sequences appear that
do no longer correspond to the originally used symbols.


-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20201116124900.be157ef7.freebsd>